diff options
author | Joris | 2022-07-05 15:05:22 +0200 |
---|---|---|
committer | Joris | 2022-07-05 15:05:22 +0200 |
commit | f02ff6b9a988db111e0384640876f20ecd0e8293 (patch) | |
tree | 2e40a88a8f10887dc985be18033682bb369ec179 /shell.nix | |
parent | 650a23ed763d8627af14ed154fdb9097a80875c5 (diff) |
Simplify tooling
Diffstat (limited to 'shell.nix')
-rw-r--r-- | shell.nix | 27 |
1 files changed, 16 insertions, 11 deletions
@@ -1,12 +1,17 @@ -with import <nixpkgs> {}; { - env = stdenv.mkDerivation { - name = "env"; - buildInputs = with nodePackages; with haskellPackages; [ - stack - nodemon - stylish-haskell - tmux - tmuxinator - ]; - }; +with (import (builtins.fetchGit { + name = "nixos-21.05-2021-08-02"; + url = "https://github.com/nixos/nixpkgs/"; + ref = "refs/heads/nixos-21.05"; + rev = "d4590d21006387dcb190c516724cb1e41c0f8fdf"; +}){}); + +mkShell { + + buildInputs = with haskellPackages; [ + cabal-install + stylish-haskell + tmux + (ghc.withPackages (hp: [ hp.zlib ])) + ]; + } |