aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJoris2025-01-31 23:27:51 +0100
committerJoris2025-01-31 23:30:45 +0100
commit9244780d6c689936d8a33a0d123d0a54ee284319 (patch)
treec5d712758e32778ec4bacc69b5ca6d3118851558 /Cargo.toml
parent1faba72b83c3c061953051f9263e67fd11d37465 (diff)
Upgrade dependenciesmain
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 5 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 6e01dcf..b8e2742 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -5,18 +5,18 @@ authors = ["Joris <joris@guyonvarch.me>"]
edition = "2021"
[dependencies]
-bcrypt = "0.16"
+bcrypt = "0.17"
chrono = "0.4"
env_logger = "0.11"
hex = "0.4"
hmac = "0.12"
http-body-util = "0.1"
-hyper = { version = "1.5", features = ["full"] }
+hyper = { version = "1.6", features = ["full"] }
hyper-util = { version = "0.1", features = ["full"] }
log = "0.4"
-minijinja = { version = "2.6", features = ["loader"] }
-rand = { version = "0.8", features = ["getrandom"] }
-rand_core = "0.6"
+minijinja = { version = "2.7", features = ["loader"] }
+rand = { version = "0.9", features = ["os_rng"] }
+rand_core = "0.9"
rusqlite = { version = "0.32", features = ["chrono"] }
serde = { version = "1.0", features = ["derive"] }
serde_json = "1.0"