diff options
author | Joris | 2016-07-04 19:36:16 +0200 |
---|---|---|
committer | Joris | 2016-07-08 01:10:25 +0200 |
commit | 52f9fafc65d81fc8f684dee21f895e85a14c8165 (patch) | |
tree | 03ca065804084857fbd9ea852754424fd9b7a9c9 /shell.nix | |
parent | ec08c799d1c1a0713d0ac6140314335950a728d5 (diff) |
Update getting started section in README
Diffstat (limited to 'shell.nix')
-rw-r--r-- | shell.nix | 19 |
1 files changed, 19 insertions, 0 deletions
@@ -6,6 +6,25 @@ with import <nixpkgs> {}; { cabal-install cabal2nix nodejs + sqlite + tmux ]; + shellHook = '' + tmux kill-session -t sharedCost >/dev/null + + urxvt -e zsh -c "tmux new-session -s sharedCost" & sleep 0.5 + tmux send-keys -t sharedCost '"$EDITOR" README.md' 'C-m' + + tmux split-window -h -t sharedCost + tmux send-keys -t sharedCost 'make install && make build && make watch' 'C-m' + + tmux select-pane -t sharedCost -L + tmux resize-pane -t sharedCost -R 25 + + firefox http://localhost:3000/ + + sleep 0.5 + kill -9 $PPID + ''; }; } |