diff options
Diffstat (limited to 'shell.nix')
-rw-r--r-- | shell.nix | 19 |
1 files changed, 19 insertions, 0 deletions
@@ -6,6 +6,25 @@ with import <nixpkgs> {}; { cabal-install cabal2nix nodejs + sqlite + tmux ]; + shellHook = '' + tmux kill-session -t sharedCost >/dev/null + + urxvt -e zsh -c "tmux new-session -s sharedCost" & sleep 0.5 + tmux send-keys -t sharedCost '"$EDITOR" README.md' 'C-m' + + tmux split-window -h -t sharedCost + tmux send-keys -t sharedCost 'make install && make build && make watch' 'C-m' + + tmux select-pane -t sharedCost -L + tmux resize-pane -t sharedCost -R 25 + + firefox http://localhost:3000/ + + sleep 0.5 + kill -9 $PPID + ''; }; } |