diff options
Diffstat (limited to 'shell.nix')
-rw-r--r-- | shell.nix | 17 |
1 files changed, 3 insertions, 14 deletions
@@ -8,23 +8,12 @@ with import <nixpkgs> {}; { nodejs sqlite tmux + tmuxinator ]; shellHook = '' - tmux kill-session -t sharedCost >/dev/null - - urxvt -e zsh -c "tmux new-session -s sharedCost" & sleep 0.5 - tmux send-keys -t sharedCost '"$EDITOR" README.md' 'C-m' - - tmux split-window -h -t sharedCost - tmux send-keys -t sharedCost 'make install && make build && make watch' 'C-m' - - tmux select-pane -t sharedCost -L - tmux resize-pane -t sharedCost -R 25 - + tmux kill-session -t sharedCost >/dev/null 2>&1 firefox http://localhost:3000/ - - sleep 0.5 - kill -9 $PPID + tmuxinator local ''; }; } |