aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJoris2024-11-17 11:07:01 +0100
committerJoris2024-11-17 11:07:01 +0100
commit0fad55124684989ec9fd9a742b5731359d0238ce (patch)
treef90d3d4ffc1b1f5e87dbaf0cc29adad069612545 /Cargo.toml
parent36cd29b459bb41bff1cf6d079fd30100bd89cec1 (diff)
Upgrade dependencies
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml14
1 files changed, 7 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a0d6f2c..356fdcf 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -5,13 +5,13 @@ edition = "2021"
[dependencies]
anyhow = "1.0"
-async-channel = "1.8"
+async-channel = "2.3"
chrono = { version = "0.4", features = [ "serde" ] }
-clap = { version = "4.0", features = ["derive"] }
-gtk4 = { version = "0.5", features = [ "v4_4" ] }
-rusqlite = { version = "0.28", features = [ "chrono" ] }
-rusqlite_migration = "1.0"
+clap = { version = "4.5", features = ["derive"] }
+gtk4 = { version = "0.9", features = [ "v4_4" ] }
+rusqlite = { version = "0.32", features = [ "chrono" ] }
+rusqlite_migration = "1.3"
serde = { version = "1.0", features = [ "derive" ] }
serde_json = "1.0"
-thiserror = "1.0"
-uuid = { version = "1.2", features = [ "v4" ] }
+thiserror = "2.0"
+uuid = { version = "1.11", features = [ "v4" ] }