diff options
author | Joris | 2020-02-02 13:53:54 +0100 |
---|---|---|
committer | Joris | 2020-02-02 13:58:19 +0100 |
commit | 0ce8744897b9aa13ea568a6985da9570e4aca90b (patch) | |
tree | 3619508ff9ec5d846c567c3562d05ca77e686c76 /shell.nix | |
parent | 13d29804ba4bb8d578fb0278ddeb6e187bbafa6f (diff) |
Use zola generator
- Use CSS instead of Haskell with Clay
- Use TypeScript instead of PureScript
Diffstat (limited to 'shell.nix')
-rw-r--r-- | shell.nix | 22 |
1 files changed, 8 insertions, 14 deletions
@@ -1,20 +1,14 @@ -with (import <nixpkgs> {}); - -haskell.lib.buildStackProject { - name = "myenv"; +with import (builtins.fetchTarball { + url = https://github.com/NixOS/nixpkgs/archive/19.09.tar.gz; + sha256 = "0mhqhq21y5vrr1f30qd2bvydv4bbbslvyzclhw0kdxmkgg3z4c92"; +}) {}; +mkShell { buildInputs = [ - zlib - stack - psc-package - (callPackage ./nix/purescript.nix {}) - nodePackages.nodemon + closurecompiler + nodePackages.typescript tmux tmuxinator - nodejs + zola ]; - - shellHook = '' - export PATH=node_modules/.bin:$PATH; - ''; } |