diff options
Diffstat (limited to 'shell.nix')
-rw-r--r-- | shell.nix | 22 |
1 files changed, 8 insertions, 14 deletions
@@ -1,20 +1,14 @@ -with (import <nixpkgs> {}); - -haskell.lib.buildStackProject { - name = "myenv"; +with import (builtins.fetchTarball { + url = https://github.com/NixOS/nixpkgs/archive/19.09.tar.gz; + sha256 = "0mhqhq21y5vrr1f30qd2bvydv4bbbslvyzclhw0kdxmkgg3z4c92"; +}) {}; +mkShell { buildInputs = [ - zlib - stack - psc-package - (callPackage ./nix/purescript.nix {}) - nodePackages.nodemon + closurecompiler + nodePackages.typescript tmux tmuxinator - nodejs + zola ]; - - shellHook = '' - export PATH=node_modules/.bin:$PATH; - ''; } |