aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorJoris2022-04-02 17:40:00 +0200
committerJoris2022-04-02 17:40:00 +0200
commit1d855b7a50b61650f7ddf40f604c788de1c9e914 (patch)
tree5dcc98fcd4fa1a1ff753010fccacf664d426d5f5 /flake.nix
parenta45ed4328fad91878ed904c7bee7539c97708500 (diff)
Use nix flakes
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..92bf81f
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,21 @@
+{
+ inputs = {
+ nixpkgs.url = "github:nixos/nixpkgs";
+ flake-utils.url = "github:numtide/flake-utils";
+ };
+
+ outputs = { self, nixpkgs, flake-utils }:
+ flake-utils.lib.eachDefaultSystem
+ (system:
+ let pkgs = nixpkgs.legacyPackages.${system};
+ in { devShell = pkgs.mkShell {
+ buildInputs = with pkgs; [
+ nodePackages.typescript
+ python3
+ psmisc
+ esbuild
+ watchexec
+ ];
+ }; }
+ );
+}