aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJoris2025-02-07 09:17:26 +0100
committerJoris2025-02-07 09:17:26 +0100
commit5e2aee9248a00c8b213a8e07e4796d668bff519c (patch)
tree861fdc7f2b23cc8538cf479f44f62e700a77222f /Cargo.toml
parent463d58b37909c976d3f30bdb5a652f0e8a018b55 (diff)
Apply SQL migrations at startup
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a890e01..04a5b41 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -5,6 +5,7 @@ authors = ["Joris <joris@guyonvarch.me>"]
edition = "2021"
[dependencies]
+anyhow = "1.0"
base64 = "0.22"
chrono = "0.4"
const_format = "0.2"
@@ -20,4 +21,5 @@ rand_core = "0.6"
tempfile = "3.15"
tokio = { version = "1", features = ["full"] }
tokio-rusqlite = "0.6"
+rusqlite_migration = "1.3"
tokio-util = "0.7"